Another Sale Lost Because of Internet Explorer

I was shopping for some printing services, and started on the Staples web site. It redirected me to their partner, “Mark The World.” I clicked on the product I was interested in, and was greeted with the message:

The web browser you are using is incompatible

We are sorry for the inconvenience. Our site currently supports only Internet Explorer version 4.0 and 5.0. This is due to the advanced features used in the real-time designer.

We are working to support Netscape in the very near future. If you do not have Internet Explorer, it may be downloaded for free at Microsoft’s website here.

How incredibly ignorant! My web browser is not incompatible. Mark the World’s web site is incompatible with industry standard browsers. What a terrible way to treat a potential customer! Kicking out customers running Safari, FireFox, Camino, Konqueror, Opera or Nautilus because Mark The World choose to go with the least secure web browser is such poor customer service. Blame the customer. Get a clue, MTW. It’s about choice. At the least, they should gracefully offer alternative services for those who prefer not to use their recommendation of browsers. I’ll take my business elsewhere.

No comments yet.

Leave a Reply

Powered by WordPress. Designed by Woo Themes

This work by Ted Roche is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 United States.